WinBatch Tech Support Home

Database Search

If you can't find the information using the categories below, post a question over in our WinBatch Tech Support Forum.

TechHome

Error Messages

Can't find the information you are looking for here? Then leave a message over on our WinBatch Tech Support Forum.

Server Error 500: Failed to Create CGI Process

Keywords:      Failed to create CGI process

Question:

We've been using your Web Batch system successfully under Windows NT server 3.51 for nearly a year now. We're running WebSite server software. The other day we upgraded to Windows NT Server 4.0. Since then we've not been able to get Web Batch CGI scripts to run -- even though WebSite is configured for them exactly as it was before. For instance, when I try to run one of the scripts via Netscape, I get the following error:
        500 Server Error

        The server encountered an internal error or misconfiguration and was
        unable to complete your request.
 
        Message: Failed to create CGI process.
Do you have any idea what may be causing this problem. I've even gone so far as to reinstall both Website and WebBatch under NT 4.0 but doing that hasn't changed our getting this error. I'd appreciate any suggestions you might have.

Answer:

It will be something dumb. Probably one of the following:
  1. Virtual Directory mapping. Makes sure webcgi or what ever you use is mapped for StdCgi or WinCgi . We recommend stdcgi - but this kind of change can affect scripts.

  2. If using WinCgi, make sure CGI WinCgi Exec parameters set to:
            ~p ~v ~i ~o ~a
    

Article ID:   W12465
Filename:   Error 500 Failed to Create CGI Process.txt
File Created: 2017:07:28:13:58:11
Last Updated: 1999:04:15:16:47:26